WordPress has introduced a way for developers to set a minimum required PHP version for their plugins.

If you are a WordPress plugin developer and want to set a minimum required PHP version for your WordPress plugin, simply add Requires PHP: to your WordPress plugin’s readme.txt file.

=== Better WP Search ===
Contributors: bhimpfen
Donate link: https://himpfen.com/
License: GPLv3
License URI: http://www.gnu.org/licenses/gpl.html
Tags: search, wordpress, wp, find
Requires at least: 4.6
Tested up to: 4.8.1
Stable tag: 5.3.3
Requires PHP: 5.2.4